Sharecodepoint popular queries
Search results for Laboratory
Showing posts with label Laboratory. Show all posts

Tuesday, 8 May 2018

CSE427 : Virtualization And Cloud Computing Laboratory End Term Practical Questions - CSE 427 - Lpu Practical

CSE427 : Virtualization And Cloud Computing Laboratory End Term Practical Questions - CSE 427 - Lpu Practical

CSE427 : Virtualization And Cloud Computing Laboratory End Term Practical Questions - CSE 427 - Lpu Practical

Thursday, 3 May 2018

CSE307 : Computer Network Lab End Term Practical Questions - CSE 307 - Lpu Lab Question Paper

CSE307 : Computer Network Lab Important Questions with Solution + Viva Questions - CSE 307

Question 1 : Router Configuration At Router 1: enable configure terminal interface serial 1 ip address 20.20.20.1 255.255....

Question 1 : Router Configuration
At Router 1:

enable
configure terminal
interface serial 1
ip address 20.20.20.1 255.255.255.0
no shutdown
interface ethernet 1
ip address 10.10.10.1 255.255.255.0
no shutdown
router rip
network 10.10.10.0
network 20.20.20.0


At Router 2:
enable
configure terminal
interface serial 1
ip address 20.20.20.2 255.255.255.0
clock rate 64000
no shutdown
interface ethernet 1
ip address 30.30.30.1 255.255.255.0
no shutdown
router rip
network 20.20.20.0
network 30.30.30.0

Question 2 : INSTALLATION OF NIC CARD in the System
  1. unplug the power cable or power supply of the system. 
  2. wear or put on the strap or guard band on the hand so that any extra current from the electronic components such as capacitors on the mother boards can be grounded. 
  3. open the side cover of the CPU case of the cabinet -then detect the  PCI(peripheral component or communication interconnect)slot. 
  4. now take the NIC card check the cut on the card 
  5. now match the cut or the notch on the card and the PCI slot 
  6. now gently insert the card from both the ends in the PCI slot 
  7. tighten the screw of the NIC card's plate to the CPU case so that card cannot move. 
  8. close the CPU case with the side cover and tighten the screw with a screw driver. 
  9. now connect the power supply to the system and start the system

Question 3 : How to locate MAC address of a computer ?
  1. open start menu 
  2. click in run 
  3. On the run window write cmd and click on ok button
  4. cmd window will get open 
  5. In cmd window write command ipconfig/all
  6. In cmd window run command ipconfig/all
  7. It will show the mac address/physical address of the computer.
Question 4: Network Commands ?

ipconfig
To verify a network connection as well as to verify your network settings

netstat
Displays active TCP connections.

tracert
The tracert command is used to visually see a network packet being sent and received.

ping
TCP/IP Networks IP address.


pathping
Give the information about network latency and network loss at intermediate between a source and destination.

ftp
FTP is short for File Transfer Protocol.

arp
Displays, adds, and removes arp information from network devices.

nslookup
Displays information that you can use to diagnose Domain Name System (DNS) infrastructure. 

nbtstat
Displays protocol statistics and current TCP/IP connections.

netsh
Netsh is to reset the TCP/IP.

getmac
 It displays MAC addresses for the local system.

Monday, 30 April 2018

CSE534 : Program in eclipse to create test cases for Sub String - Software Testing and Quality Assurance laboratory - CSE 534 by Aniket Pramanik

Information about the quality of the software product or service under test. Program in eclipse to create test cases for Sub String :...
Information about the quality of the software product or service under test.

Program in eclipse to create test cases for Sub String :

SubString.java
package programs;

public class SubStr {
public  boolean subString(String str1,String str2) {
	boolean flag=false;
	for(int i=0;i<str1.length();i++) {
		if(str2.equals(str1.substring(i))) {
			flag=true;
		}
	}
	return flag;
}
}

SubStringTest.java
package programs;

import static org.junit.Assert.*;

import org.junit.After;
import org.junit.Before;
import org.junit.Test;

public class SubStrTest {
SubStr s;
	@Before
	public void setUp() throws Exception {
	s=new SubStr();}

	@After
	public void tearDown() throws Exception {
	s=null;}

	@Test
	public void test() {
		assertEquals(true,s.subString("welcome", "come"));
		assertEquals(false,s.subString("welcome", "comelo"));
	}

}
About Developer
Aniket Pramanik
I love to make things simple :)

CSE534 : Program in eclipse to create test cases for String Equal - Software Testing and Quality Assurance laboratory - CSE 534 by Aniket Pramanik

Information about the quality of the software product or service under test. Program in eclipse to create test cases for String Equal...
Information about the quality of the software product or service under test.

Program in eclipse to create test cases for String Equal : 

StringEqual.java
package programs;

public class StringEqual {
public boolean strEqual(String str1,String str2) {
	boolean flag=false;
	
	if(str2.equals(str1)){
			flag=true;
		}
	return flag;
}
}

StringEqualTest.java
package programs;

import static org.junit.Assert.*;

import org.junit.After;
import org.junit.Before;
import org.junit.Test;

public class StringEqualTest {
StringEqual s;
	@Before
	public void setUp() throws Exception {
	s=new StringEqual();}

	@After
	public void tearDown() throws Exception {
	}

	@Test
	public void test() {
		assertEquals(true,s.strEqual("aniket", "aniket"));
		assertEquals(false,s.strEqual("aniket", "aniketp"));
		assertEquals(false,s.strEqual("aniket","et"));
		assertEquals(false,s.strEqual("welcome", "come"));
	}

}
About Developer
Aniket Pramanik
I love to make things simple :)

CSE534 : Program in eclipse to create test cases for StringConcat - Software Testing and Quality Assurance laboratory - CSE 534 by Aniket Pramanik

Information about the quality of the software product or service under test.  Program in eclipse to create test cases for String Co...
Information about the quality of the software product or service under test.


 Program in eclipse to create test cases for String Concat

StringConcat.java
package programs;

public class StringConcat {
public String concat(String str1,String str2) {
	String nStr="";
	nStr=str1.concat(str2);
	return nStr;
}
}

StringConcatTest.java
package programs;

import static org.junit.Assert.*;

import org.junit.After;
import org.junit.Before;
import org.junit.Test;

public class StringConcatTest {
StringConcat str;
	@Before
	public void setUp() throws Exception {
	str=new StringConcat();}

	@After
	public void tearDown() throws Exception {
	str=null;}

	@Test
	public void test() {
		assertEquals("aniketPramanik",str.concat("aniket","Pramanik"));
	}

}
About Developer
Aniket Pramanik
I love to make things simple :)

CSE534 : Program in eclipse to create test cases for Special Char - Software Testing and Quality Assurance laboratory - CSE 534 by Aniket Pramanik

Information about the quality of the software product or service under test. Program in eclipse to create test cases for Special Char...
Information about the quality of the software product or service under test.

Program in eclipse to create test cases for Special Char

specialchar.java
package programs;

public class SpecialChar {
public String filter(String x) {
	String str="";
	str=x.replaceAll("[-+^:~!@#$%&()<>]", "");
	System.out.println(str);
	return str;
}
}

specialchartest.java
package programs;

import static org.junit.Assert.*;

import org.junit.After;
import org.junit.Before;
import org.junit.Test;

public class SpecialCharTest {
SpecialChar x;
	@Before
	public void setUp() throws Exception {
	x=new SpecialChar();}

	@After
	public void tearDown() throws Exception {
	x=null;}

	@Test
	public void test() {
		assertEquals("aniket",x.filter("a#nik-et+"));
	}

}
About Developer
Aniket Pramanik
I love to make things simple :)

CSE534 : Program in eclipse to create test cases for Reverse String - Software Testing and Quality Assurance laboratory - CSE 534 by Aniket Pramanik

Information about the quality of the software product or service under test.  Program in eclipse to create test cases for Reverse Str...
Information about the quality of the software product or service under test.

 Program in eclipse to create test cases for Reverse String using java 

ReverseStr.java
package programs;

public class ReverseStr {
 String rev(String a) {
	String str="";
	for(int i=a.length()-1;i>=0;i--) {
		str=str+a.charAt(i);
	}
	return str;
}
}

ReverseStrTest.java
package programs;

import static org.junit.Assert.*;

import org.junit.After;
import org.junit.Before;
import org.junit.Test;

public class ReverseStrTest {
ReverseStr s;
	@Before
	public void setUp() throws Exception {
	s=new ReverseStr();}

	@After
	public void tearDown() throws Exception {
	s=null;}

	@Test
	public void test() {
		assertEquals("tac",s.rev("cat"));
	}

}
About Developer
Aniket Pramanik
I love to make things simple :)

CSE534 : Program in eclipse to create test cases for Reverse Number - Software Testing and Quality Assurance laboratory - CSE 534 by Aniket Pramanik

Information about the quality of the software product or service under test. Program in eclipse to create test cases for Reverse Numb...
Information about the quality of the software product or service under test.

Program in eclipse to create test cases for Reverse Number 
reverse.java
package programs;

public class Reverse {
	public int rev(int a) {
		int rev=0;
		
		while(a!=0) {
			int last=a%10;
			rev=rev*10+last;
			a=a/10;	
		}
		return rev;
	}
}

reversetest.java
package programs;

import static org.junit.Assert.*;

import org.junit.After;
import org.junit.Before;
import org.junit.Test;

public class ReverseTest {
Reverse  r;
	@Before
	public void setUp() throws Exception {
	r=new Reverse();}

	@After
	public void tearDown() throws Exception {
	r=null;}

	@Test
	public void test() {
		assertEquals(4321,r.rev(1234));
	}

}
About Developer
Aniket Pramanik
I love to make things simple :)

CSE534 : Program in eclipse to create test cases for Product Digit - Software Testing and Quality Assurance laboratory - CSE 534 by Aniket Pramanik

Information about the quality of the software product or service under test. Program in eclipse to create test cases for Product Digi...
Information about the quality of the software product or service under test.

Program in eclipse to create test cases for Product Digit 
ProductDigit.java
package programs;

public class ProductDigit {
public int prod(int a) {
	int p=1;
	while(a!=0) {
	int last=a%10;
	 p=p*last;
	 a=a/10;
	 }
	return p;
}
}

ProductDigitTest.java
package programs;

import static org.junit.Assert.*;

import org.junit.After;
import org.junit.Before;
import org.junit.Test;

public class ProductDigitTest {
ProductDigit p;
	@Before
	public void setUp() throws Exception {
	p=new ProductDigit();
	}

	@After
	public void tearDown() throws Exception {
	p=null;}

	@Test
	public void test() {
		assertEquals(10,p.prod(25));
	}
}
About Developer
Aniket Pramanik
I love to make things simple :)

CSE534 : Program in eclipse to create test cases for Power - Software Testing and Quality Assurance laboratory - CSE 534 by Aniket Pramanik

Information about the quality of the software product or service under test. Program in eclipse to create test cases for Power using ...
Information about the quality of the software product or service under test.

Program in eclipse to create test cases for Power using java :

Power.java
package programs;

public class Power2 {
	public int pow(int x) {
		int flag=0;
		
		while(x!=0) {
			int rem=x%2;
			if(rem==1) {
				flag++;
				}
				x=x/2;
		
		}
		return flag;
	}

}

PowerTest.java
package programs;

import static org.junit.Assert.*;

import org.junit.After;
import org.junit.Before;
import org.junit.Test;

public class Power2Test {
Power2 p;
	@Before
	public void setUp() throws Exception {
	p=new Power2();
	}

	@After
	public void tearDown() throws Exception {
	}

	@Test
	public void test() {
	assertEquals(1,p.pow(64));
	}
}
About Developer
Aniket Pramanik
I love to make things simple :)

CSE534 : Program in eclipse to create test cases for Prime Number - Software Testing and Quality Assurance laboratory - CSE 534 by Aniket Pramanik

Information about the quality of the software product or service under test. Program in eclipse to create test cases for Prime Number...
Information about the quality of the software product or service under test.

Program in eclipse to create test cases for Prime Number : 

PrimeNum.java
package programs;

public class PrimeNum {
 public boolean prime(int x) {
  boolean flag=true;
for(int i=2;i<=x/2;i++) {
 if(x%i==0) {
 flag=false;
 break;
 }
}
  return flag;
 }
}

PrimeNumTest.java
package programs;

import static org.junit.Assert.*;

import org.junit.After;
import org.junit.Before;
import org.junit.Test;

public class PrimeNumTest {
PrimeNum x;
 @Before
 public void setUp() throws Exception {
 x=new PrimeNum();}

 @After
 public void tearDown() throws Exception {
 x=null;}

 @Test
 public void test() {
  assertTrue("Result",x.prime(5));
  assertEquals(false,x.prime(9));
 }
}
About Developer
Aniket Pramanik
I love to make things simple :)

CSE534 : Program in eclipse to create test cases for Maximum Array (Max Array) - Software Testing and Quality Assurance laboratory - CSE 534 by Aniket Pramanik

Information about the quality of the software product or service under test. Program in eclipse to create test cases for Maximum Arra...
Information about the quality of the software product or service under test.

Program in eclipse to create test cases for Maximum Array (Max Array) : 

MaxArray.java 
package programs;

public class MaxArray {
public int max(int a[]) {
int max=a[0];
for(int i=0;i<a.length;i++) {
 if(max<a[i]) 
  max=a[i];
   
}
System.out.println("max="+max);
return max;
}

}

MaxArrayTest.java
package programs;

import static org.junit.Assert.*;

import org.junit.After;
import org.junit.Before;
import org.junit.Test;

public class MaxArrayTest {
MaxArray m;
 @Before
 public void setUp() throws Exception {
 m=new MaxArray();}

 @After
 public void tearDown() throws Exception {
 }

 @Test
 public void test() {
  int[] a= {5,3,4,10,8};
assertEquals(10,m.max(a));
  
 }

}
About Developer
Aniket Pramanik
I love to make things simple :)

CSE534 : Program in eclipse to create test cases for Max (Maximum Number find ) using java - Software Testing and Quality Assurance laboratory - CSE 534 by Aniket Pramanik

Information about the quality of the software product or service under test.  Program in eclipse to create test cases for Max (Maximu...
Information about the quality of the software product or service under test.

 Program in eclipse to create test cases for Max (Maximum Number find ) using java :

max.java
package programs;

public class Max {
public int maximum(int a,int b,int c) {
 int max=a;
 if((b>a)&&(b>c)) 
  return max=b;
 if(c>a &&c>b) {
  return max=c;}
  
  
 else
 return max;
}
}

maxtest.java
package programs;

import static org.junit.Assert.*;

import org.junit.After;
import org.junit.Before;
import org.junit.Test;

public class MaxTest {
Max n;
 @Before
 public void setUp() throws Exception {
 n=new Max();
 }

 @After
 public void tearDown() throws Exception {
 n=null;}

 @Test
 public void test() {
  assertEquals(3,n.maximum(1, 3, 2));
  assertEquals(3,n.maximum(1, 2, 3));
  assertEquals(3,n.maximum(3,0, 2));
 }

}
About Developer
Aniket Pramanik
I love to make things simple :)

CSE534 : Program in eclipse to create test cases for Linear Search using java - Software Testing and Quality Assurance laboratory - CSE 534 by Aniket Pramanik

Information about the quality of the software product or service under test. Program in eclipse to create test cases for Linear Searc...
Information about the quality of the software product or service under test.

Program in eclipse to create test cases for Linear Search

LinearSearch.java
package programs;
import java.util.*;

public class LinearSearch {
 Scanner sc=new Scanner(System.in);
 public int[] input() {
 int a[]=new int[5];
 
 System.out.println("Enter 5 numbers:");
 for(int i=0;i<5;i++) {
  a[i]=sc.nextInt();
 }
 return a;
}
 public boolean search(int a[]) {
  boolean flag=false;
  System.out.println("Enter number to be searched:");
  int num=sc.nextInt();
  for(int i=0;i<a.length;i++) {
   if(num==a[i]) {
    flag=true;
    break;
   }
  }
  return flag;
 }

}

LinearSearchtest.java
package programs;

import static org.junit.Assert.*;

import org.junit.After;
import org.junit.Before;
import org.junit.Test;

public class LinearSearchTest {
LinearSearch l;
 @Before
 public void setUp() throws Exception {
 l=new LinearSearch();}

 @After
 public void tearDown() throws Exception {
 l=null;}

 @Test
 public void test() {
  //assertTrue("Result",l.search(l.input()));//if it is used so both the statemnt below should be comment
  assertEquals(true,l.search(l.input()));
  assertEquals(false,l.search(l.input()));
 }

}
About Developer
Aniket Pramanik
I love to make things simple :)

 

Version 23.2.3.4 - 2016 - 2020 - © Sharecodepoint | Made in India. | Copyright Content | Facebook | Twitter | Instagram | Youtube